Проблем съв admin models плъгин

В този раздел можете да подадете заявка за преработка на даден плъгин. Имайте предвид, че задължително трябва да преодставите кода на въпросния плъгин.
Отговори
Потребителски аватар

Автор на темата
MadNESs MurdaBoy
Потребител
Потребител
Мнения: 78
Регистриран: 21 мар 2017, 21:43
Репутация: 0
Местоположение: Бели брези
Контакти:

Проблем съв admin models плъгин

Мнение от MadNESs MurdaBoy » 14 юли 2018, 01:38

Здравейте имам следния проблем
Изображение
Не ми зарежда само скина на CT
използвам следният плъгин:

Код: Избери всички

#include <amxmodx>
#include <cstrike>
#include <hamsandwich>

#define MAX_MODELS 32

enum _:Data
{
	Flags[32],
	TModel[32],
	CTModel[32]
}

new const g_szModels[][Data] = 
{
	{ "m", "MadnessArmyT", "MadnessArmyCt" },
	{ "n", "MadnessArmyT", "MadnessArmyCt" },
	{ "o", "MadnessArmyT", "MadnessArmyCt" },
	{ "p", "MadnessArmyT", "MadnessArmyCt" }
}

new g_iFlags[MAX_MODELS]

public plugin_init()
{
	register_plugin("Admin Models", "1.0", "OciXCrom")
	RegisterHam(Ham_Spawn, "player", "OnPlayerSpawn", 1)
}

public plugin_precache()
{
	for(new i; i < sizeof(g_szModels); i++)
	{
		precache_player_model(g_szModels[i][TModel])
		precache_player_model(g_szModels[i][CTModel])
		g_iFlags[i] = read_flags(g_szModels[i][Flags])
	}
}

public OnPlayerSpawn(id)
{
	if(!is_user_alive(id))
		return
	
	new bool:bMatch
		
	for(new i, iFlags = get_user_flags(id); i < sizeof(g_szModels); i++)
	{
		if((iFlags & g_iFlags[i]) == g_iFlags[i])
		{
			cs_set_user_model(id, g_szModels[i][cs_get_user_team(id) == CS_TEAM_CT ? CTModel : TModel])
			bMatch = true
			break
		}
	}
	
	if(!bMatch)
		cs_reset_user_model(id)
}	
	
precache_player_model(szModel[])
{
    static szFile[128]
    formatex(szFile, charsmax(szFile), "models/player/%s/%s.mdl", szModel, szModel)
    precache_model(szFile)
    replace(szFile, charsmax(szFile), ".mdl", "T.mdl")
    
    if(file_exists(szFile))
        precache_model(szFile)
}

Потребителски аватар

You Owe Me A-G
Потребител
Потребител
Мнения: 153
Регистриран: 07 мар 2018, 19:34
Репутация: 2
Местоположение: Пред компютъра
Години: 18

Проблем съв admin models плъгин

Мнение от You Owe Me A-G » 14 юли 2018, 01:43

Вижда си проблема, няма ти го модела MadnessArmyCtT, имаше урок как скиновете могат да вървят и без втория модел, който е T, но не знам къде беше...

Отговори

Върни се в “Преработка на плъгини”

Кой е на линия

Потребители, разглеждащи този форум: Няма регистрирани потребители и 0 госта